Validating .travis.yml files

Follow

Comments

2 comments

  • Avatar
    yunnysunny

    When I used ruby 1.9.3 to install travis, it will result an error:

    ```

    ERROR: Error installing travis:
    ffi requires Ruby version < 2.7.dev, >= 2.2.

    ```

    But when I changed the version of ruby to 2.6.1, it will result another error:

    ```

    ERROR: While executing gem ... (OptionParser::InvalidOption)
    invalid option: --no-rdoc

    ```

    I'm confused how to install travis properly.

    Then I googled the error message, and found that changing the option to `--no-document` can resolve this problem.

  • Avatar
    Sorin Sbarnea

    Please correct the documentation to avoid the need for root access:

    gem install travis --user-install --no-rdoc --no-ri

Please sign in to leave a comment.